日本-日本語

製品  >  ソフトウェア  >  OpenVMS  >  マニュアル

OpenVMS マニュアル


≫ 

OpenVMS V8.3
ライブラリ

タイトルページ
目次
まえがき
第 1 章:本書の概要
第 2 章:一般ユーザ向けリリース・ノート
第 3 章:システム管理者向けリリース・ノート
第 4 章:プログラミングに関するリリース・ノート
第 5 章: 関連ドキュメントに関するリリース・ノート
第 6 章:日本語機能に関するリリース・ノート
付録 A :OSF/Motif リリース 1.2 リリース・ノート
付録 B :OSF/Motif サンプル・プログラム
索引
PDF
OpenVMS ホーム
日本語 HP DECwindows Motif for OpenVMS | HPE 日本

日本語 HP DECwindows Motif
for OpenVMS
リリース・ノート


目次 索引



V1.2

viewプログラムは, Motifの国際化サポートを使用した DCL コマンドの TYPE/PAGE と似ています。このプログラムによって,ファイルを数カ国語で表示することができます。

用意されているコマンド・ファイル DECW$EXAMPLES:FILEVIEW.COM を使用して,各国の言語を選ぶことができます。有効な言語は,フランス語,英語,およびドイツ語です。言語を選択するには,次のコマンドを実行してください。


$ SET DEFAULT DECW$USER_DEFAULTS
$ @DECW$EXAMPLES:FILEVIEW language

このコマンド・ファイルでは, .UID および .DAT の各ファイルを現在のディレクトリに複写するとともに,適切なロケールを設定し,ファイル表示のための view プログラム例を実行します。

アプリケーションが起動されると,1次の最上位のシェルが作成されます。 1次の最上位のシェルから,2次シェルを作成することができます。

各最上位のシェルはメイン・ウィンドウの親に当たります。メイン・ウィンドウの作業領域が PanedWindow です。

メニュー・バーには,次のエントリがあります。

  • File
    ファイルのオープンとクローズ,新しいシェルの作成,ならびに終了。

  • View
    ウィンドウ・パネル内の作業領域の制御。

ファイル・メニュー

ファイル・メニューには次のオプションが含まれています。

  • 新しいファイルをオープン
    ファイル選択ボックスは,ファイル選択用にマッピングされています。 OpenFileが正常に実行されると,現在のファイルがクローズされて,既存の作業領域はすべて破壊され,新しいファイルが表示されます。

  • 新しいシェルをオープン
    1次シェルに類似した2次シェルを作成します。ファイルは,各シェルごとに別々に表示することができます。

  • クローズ
    このエントリは2次ウィンドウにだけあります。これによって最上位のシェルを破壊し,ファイルをクローズします。

  • 終了
    このエントリは1次シェルにだけあります。これによってファイルおよびシェルをクローズします。

表示メニュー

表示メニューには,次のオプションが含まれています。

  • 新しい作業領域
    ウィンドウ・パネルの中に新しい作業領域を作成します。

  • 作業領域の削除
    現在の作業領域を削除します。

  • 検索
    [検索]により,ファイル内のテキストを検索するためにダイアログ・ボックスがポップアップ表示されます。ダイアログ・ボックスの[了解]のコールバックで文字列の検索を行います。検索する文字列が見つかると現在の作業領域に表示されます。その文字列が見つからない場合は,ダイアログ・ボックスがポップアップ表示されます。

1つのウィンドウ内でもう1つ別のファイルを開こうとすると,アプリケーションは突然終了します。この場合,表示メニューは正常に作動しません。

B.12 Xmpiano プログラム例

V1.2

xmpiano プログラムは MIDI (Motif Interface to Dumb Instruments) アプリケーションの書き込み方法を示します。譜表は,楽譜を書くためにも,キーボードのためにも使用することができます。

ウィンドウの下部には,譜表上で使用するための音符のセットがあります。音符ボタンの1つを選択すると,それに従って使用される音符が変わります。選択した音符は,マウスのカーソルとして表示されます。

選択できる音符の種類は制限されたものですが,自然音階のほかに,シャープも選択可能です。プログラムのインタフェースは,フラットの音階をサポートしていません。譜表は,音符が書き加えられて右端を超えると自動的に延長されます。右端を超えたところにある音符は,必要に応じて楽譜のウィンドウをスクロールすることで表示できます。

このアプリケーションを使用するには,表示された譜表の上でマウスの右ボタンを押します。これによって次のメニュー項目が表示されます。

  • 音声追加 (Add Voice)
    新しい譜表に別のディスプレイを接続します。このコマンドを選択すると,接続すべきディスプレイを求めるプロンプトが出ます。新しい譜表に書かれた楽譜は,このディスプレイで演奏されます。新しい譜表上でマウスの右ボタンを押すと,メニュー・タイトルにこのディスプレイの名前が表示されること,また,メニュー・バーのメニュー・コマンドは表示されている譜表に関連したものであることに注意してください。

  • 音声削除(Remove Voice)
    接続されたディスプレイとともに譜表を削除します。このコマンドには,取消はありません。したがって,この譜表に書かれた楽譜はすべて削除されます。

  • 音声消去(Clear Voice)
    譜表上の音符をすべて消去します。ディスプレイとの接続は,これによって影響されません。

  • 音声演奏(Play Voice)
    マウスの右ボタンを譜表の上で押すと,その譜表に記入された音声を演奏します。音声がローカル・ホストと同一の場合,音符が演奏されるのにつれて音符に対応するキーボード上のキーが押されたかのように表示されます。キーボードに,同時に複数の音声を組み合わせた演奏をさせることも可能ですが,このためには -DCHORDS オプションを使用してコードをコンパイルしなければなりません。これによって多くのサーバのアプリケーション処理が著しく遅延することに注意してください。

  • 全部の演奏(Play All)
    指定された各ディスプレイのすべての音声を同時演奏します。

  • 音声保管(Save Voice)
    対応する音声をファイルに保管します。その音声を保管するファイル名入力のプロンプトのためにファイル選択ダイアログ(FileSelectionDialog)が表示されます。ディスプレイ接続関係の情報は保管されません。

  • 音声のロード(Load Voice)
    すでに保管されている音声を対応する譜表にロード(追加)します。

  • 終了(Quit)
    このプログラム例を終了します。

本バージョンでは,音符を操作して編曲することはできません。編曲するには,譜表を消去して再度入力するか,保管ファイルからデータを読み込みます。

音符の色を設定するには,アプリケーションの前景色を変更します。このためにはコマンド・ラインで -fg オプションを使用します。次の例を参照してください。


$ xmpiano :== $DECW$EXAMPLES:xmpiano
$ xmpiano -fg blue



B.13 Xmtravel プログラム例

V1.2

xmtravel プログラムは,旅行代理店関係やフライト・データベース向けのプログラム例です。このプログラムによって,『OSF/Motif スタイル・ガイドリリース 1.2』に準拠したさまざまなユーザ・インタフェースの設計概念を知ることができます。

このプログラムはほんの一例に過ぎず,装備されていない機能も多く,使用を目的とした定義済設定も行われていません。

B.14 Motif サンプル・プログラム

V1.2

表 B-3 の表には, Motif ツールキットのさまざまな機能の一覧が掲載されています。

表 B-3 Motif サンプル・プログラム
ファイル名 説明
xmdialogs.c ダイアログ・サンプラ
xmfonts.c フォント検索用
xmeditor.c テキスト・エディタ
xmlist.c 例の一覧表示用
xmprotocol.c ウィンドウ・マネージャ・プロトコルの例
xmter.c 図形とアニメーションの例
xmform.c フォーム・アタッチメントの例
xmforc.c フォーム・アタッチメントと行・列の例
xmmap.c 描画領域とスクロールされたウィンドウの例
xmgetres.c リソース取り出しの例
xmapdef.c app の定義によるスクロールされたウィンドウの例

これらのサンプル・プログラムには,次の項目が適用されます。

  1. xmfonts プログラムは,省略時の設定では字数が10文字以下のフォント名だけを表示します。システムによっては,フォント・パスには長い XLFD フォント名しか含まれていないものもあります。したがって, XMFONTS*maxLenのリソースをより大きな数字(80)に設定するか, numColumns のリソースを 1 に指定する必要があります。

  2. xmter プログラムを Motif ウィンドウ・マネージャ以外のウィンドウ・マネージャで実行する場合,そのウィンドウ・マネージャは(たとえばマットのような) ウィンドウの装飾をすべて削除する必要があります。 xmter プログラムから Motif ウィンドウ・マネージャに対して,ウィンドウの装飾を削除するように指示が出されます。

  3. xmform プログラムでは,Form に組み込まれた Motif ウィジェットで構成された文字列を表示できます。このためには次のコマンドを使用してください。


    $ xmform :== $DECW$EXAMPLES:xmform
    $ xmform string
    

    stringの変数はオプションです。 stringを指定する場合に使用できる文字は,F,I,M,O,T です。使用する文字列は必ず大文字で,引用符(" ")で囲まなければなりません。 stringが省略された場合,xmform は"MOTIF"に戻ります。

  4. xmgetres プログラムは,XmGetSecondaryResourceData の使用法を示す例です。 xmgetres を起動するには次のコマンドを使用します。


    $ xmgetres :== $DECW$EXAMPLES:xmgetres
    $ xmgetres WidgetClass
    

    WidgetClass の変数はオプションです。 WidgetClassが省略された場合, "Widget"という省略時のクラスに戻ります。 "All"のクラスも使用できます。この設定では Xt と Motif のすべてのウィジェットに対するリソースが表示されます。



B.15 プログラム例のリソース・ファイル

V1.2

プログラム例の多くには,それらの表示属性を定義する関連リソース・ファイルがあります。これらのリソース・ファイルを使用するには, DECW$EXAMPLES ディレクトリからユーザの DECW$USER_DEFAULTS ディレクトリに複写を行うか,あるいはファイルの内容をユーザの DECW$XDEFAULTS.DAT ファイルに追加します。

プログラム例ファイルおよびその関連リソース・ファイルの一覧を次の表に示します。

プログラム例 リソース・ファイル
DECW$CDPLAYER.EXE DECW$CDPLAYER.DAT
FILEVIEW.EXE FILEVIEW.DAT
PERIODIC.EXE PERIODIC.DAT
MOTIFANM.EXE MOTIFANIM.DAT
XMAPDEF.EXE XMDEMOS.DAT
XMDIALOGS.EXE XMDEMOS.DAT
XMEDITOR.EXE XMDEMOS.DAT
XMFONTS.EXE XMDEMOS.DAT
XMFORC.EXE XMDEMOS.DAT
XMFORM.EXE XMDEMOS.DAT
XMGETRES.EXE XMDEMOS.DAT
XMLIST.EXE XMDEMOS.DAT
XMMAP.EXE XMDEMOS.DAT
XMPROTOCOL.EXE XMDEMOS.DAT
XMTER.EXE XMDEMOS.DAT
XMTRAVEL.EXE XMTRAVEL.DAT

リソース・ファイルが見つからない場合には,プログラム例は実行されますが,正しく表示されないこともあります。


索引 目次

印刷用画面へ
プライバシー 本サイト利用時の合意事項