日本-日本語

製品  >  ソフトウェア  >  OpenVMS  >  マニュアル

OpenVMS マニュアル


≫ 

OpenVMS V7.3-2
ライブラリ

タイトルページ
目次
まえがき
第 1 部:デバッガ概要
第 1 章:デバッガ概要
第 2 部:コマンド・インタフェース
第 2 章:デバッガの起動
第 3 章:プログラム実行の制御とモニタ
第 4 章:プログラム・データの検査と操作
第 5 章:プログラム内シンボルへのアクセス制御
第 6 章:ソース・コードの表示の制御
第 7 章:画面モード
第 3 部:DECwindows インタフェース
第 8 章:DECwindows Motifインタフェースの概要
第 9 章:デバッグ・セッションの開始と終了
第 10 章:デバッガの使用方法
第 4 部:PC クライアント・インタフェース
第 11 章:デバッガの PC クライアント/サーバ・インタフェースの概要
第 5 部:高度なトピック
第 12 章:ヒープ・アナライザの使用
第 13 章:その他の便利な機能
第 14 章:特殊なデバッグ
第 15 章:マルチプロセス・プログラムのデバッグ
第 16 章:ベクタ化されたプログラムのデバッグ
第 17 章:タスキング・プログラムのデバッグ
第 6 部:付録
付録 A :定義済みのキー機能
付録 B :組み込みシンボルと論理名
付録 C :各言語に対するデバッガ・サポートの要約
付録 D :EIGHTQUEENS.C
索引
PDF
OpenVMS ホーム

HP OpenVMS
デバッガ説明書


目次 索引



レジスタ・ビューには,すべての機械語レジスタの現在の内容が表示されます ( 図 10-20 を参照 )。

レジスタ・ビューを表示するには,メイン・ウィンドウまたはオプション・ビュー・ウィンドウの「Options」メニューで「Views...」を選択し,「Views」ダイアログ・ボックスが表示されたら,「Registers」をクリックします。

省略時の設定では,レジスタ・ビューには現在実行が一時停止しているルーチンに対応するレジスタ値が自動的に表示されます。プログラムからデバッガに制御が戻ると,プログラムの実行で変更されたすべての値が強調表示されます。

呼び出しスタック内の任意のルーチンに対応するレジスタ値を表示するには,メイン・ウィンドウの「Call Stack」メニューでその名前を選択します ( 第 10.6.2 項 を参照 )。

レジスタに格納されている値を変更するには,次の手順に従ってください。

  1. レジスタ・ビュー内のレジスタ値をクリックする。小さな編集可能ダイアログ・ボックスが現在値の上に表示される。

  2. そのダイアログ・ボックスに新しい値を入力する。

  3. ダイアログ・ボックス内のチェック・マーク(OK)をクリックする。ダイアログ・ボックスが消えて新しい値が表示され,その値がレジスタに入ったことが示される。レジスタの値を変更せずにダイアログ・ボックスを消去するときは, X (Cancel) をクリックする。

レジスタ値の表示に使用する基数は,次の方法で変更できます。

  • 選択されたレジスタの現在の出力とそれ以降の出力の基数を変更するには,「Register」メニューで「Change Radix」を選択する。

  • すべてのレジスタの現在の出力とそれ以降の出力の基数を変更するには,「Register」メニューで「Change All Radix」を選択する。

図 10-20 レジスタ・ビュー




命令ビューには,ユーザ・プログラムのデコード済み命令ストリーム,つまり実際に実行されているコード ( 図 10-21 を参照 ) が表示されます。命令ビューが役立つのは,コンパイラによって最適化されたプログラムのデバッグ中は,メイン・ウィンドウの情報が実行中のコードと正確に対応していない場合です ( 第 1.2 節 を参照 )。

命令ビューを表示するには,メイン・ウィンドウまたはオプション・ビュー・ウィンドウの「Options」メニューで「Views...」を選択し,「Views」ダイアログ・ボックスが表示されたら,「Instructions」をクリックします。

省略時の設定では,命令ビューには現在実行が一時停止しているルーチンのデコード済み命令ストリームが自動的に表示されます。命令の左にある現在位置ポインタは,次の実行命令を示します。

省略時の設定では,命令に対応するソース・コードの行番号が命令の左に表示されます。行番号を表示するか表示しないか指定するには,命令ビューの「File」メニューで「Display Line Numbers」を選択します。

省略時の設定では,命令の左にメモリ・アドレスが表示されます。アドレスを表示するか表示しないか指定するには,命令ビューの「File」メニューで「Show Instruction Addresses」を選択します。

命令ビューでの操作が終了したら,「Call Stack」メニューをクリックして,実行の停止箇所を再表示できます。

呼び出しスタック内のルーチンの命令ストリームを表示するには,メイン・ウィンドウの「Call Stack」メニューでそのルーチンの名前を選択します ( 第 10.6.2 項 を参照 )。

図 10-21 命令ビュー




タスキング・プログラムは 1 つのプロセス内に複数の実行スレッドを持っており,次のプログラムを含んでいます。

  • DECthreads か POSIX 1003.1b サービスを使用する言語で書かれたプログラム。

  • 言語固有のタスキング・サービス ( その言語が直接用意しているサービス ) を使用するプログラム。現在のところ,デバッガがサポートする組み込みタスキング・サービスを用意している言語は Ada だけである。

デバッガで使用する タスク という用語はこのような制御の流れを示すものであり,言語や実現方法とは関係ありません。デバッガのタスキング・サポートは,このようなプログラムすべてに適用されます。

デバッガを使用すれば,タスクの情報を表示したり,タスクの実行,優先順位,状態の遷移などを制御するタスク特性を変更したりできます。

次の各節ではデバッガの DECwindows Motif for OpenVMS ユーザ・インタフェースのタスキング機能を要約します。デバッガのタスキング・サポートについての詳しい説明は, 第 17 章 を参照してください。

10.9.1 タスク情報の表示

プログラムのタスク情報を表示するには,メイン・ウィンドウまたはオプション・ビュー・ウィンドウの「Options」メニューで「Views...」を選択し,「Views」ダイアログ・ボックスが表示されたら,「Tasking」をクリックします。

このタスキング・ビューには,ユーザ・プログラム内に現在存在している ( 終了していない ) すべてのタスクの情報が表示されます。プログラムからデバッガに制御が戻ると,タスク情報が更新されます ( 図 10-22 を参照 )。

図 10-22 タスキング・ビュー


次の各情報が表示されます。

  • タスク ID。左欄の矢印は,アクティブ・タスク,つまり「Go」ボタンか「Step」ボタンのクリック時に実行されるタスクを示す。

  • タスク優先順位。

  • タスクが保留されているかどうか ( 第 10.9.2 項 を参照 )。

  • タスクの現在の状態。「RUN」状態 ( 実行中 ) のタスクがアクティブ・タスクである。

  • タスクの現在の副次状態。タスクが現在の状態になった原因を示す。

  • タスク ( スレッド ) オブジェクトのデバッガ・パス名。デバッガがタスク・オブジェクトをシンボル化できない場合はタスク・オブジェクトのアドレス。



10.9.2 タスク特性の変更

デバッグ中にタスクの特性やタスキング環境を変更するには,「Task」メニューで次のいずれかの項目を選択します。

「Tasks」メニューの項目 機能
Abort 選択されたタスクを次に終了可能なときに終了するように要求する。実際にどのように実行されるかは,現在のイベント・ファシリティにより異なる(言語固有)。 Adaのタスクの場合,強制終了文の実行と同じである。
Activate 選択されたタスクをアクティブ・タスクにする。
Hold 選択されたタスクを保留にする。
Nohold 選択されたタスクの保留を解除する。
Make Visible 選択されたタスクを可視タスクにする。
All サブメニューを使用してすべてのタスクを強制終了したり,すべてのタスクの保留を解除する。



10.10 デバッガの DECwindows Motif for OpenVMS インタフェースのカスタマイズ

デバッガは,省略時のデバッガ・リソース・ファイル (DECW$SYSTEM_DEFAULTS:VMSDEBUG.DAT) と一緒にシステムにインストールされます。このリソース・ファイルでは,次のようなカスタマイズ可能なパラメータで,省略時の起動設定を定義します。

  • ウィンドウとビューの構成

  • メイン・ウィンドウの行番号を表示するか表示しないかの指定

  • ボタン名および対応するデバッガ・コマンド

  • 条件付きブレークポイントとアクション・ブレークポイントのダイアログ・ボックスを表示するキー・シーケンス

  • ソース・ビューと命令ビューにおける,テキストの言語依存の選択用キー・シーケンス

  • ビューのテキストの文字フォント

  • 各ウィンドウとビューに表示されるテキスト用の文字フォント

  • ソース・ビュー,命令ビュー,エディタ・ビューにおける,テキストの前景色と背景色

  • メイン・ウィンドウ・タイトル・バー上の,プログラム,モジュール,ルーチン名の表示

  • デバッガを終了する前に確認が出るようにするかどうかの設定

説明用のコメントを入れた,システムの省略時デバッガ・リソース・ファイルは, 例 10-1 に掲載されています。これらの表示属性のうち,最初の 3 つの事項については, 第 10.10.1 項第 10.10.2 項 ,および 第 10.10.3 項 で説明する方法で DECwindows Motif for OpenVMS ユーザ・インタフェースにより会話形式で制御できます。どの場合も,「Options」メニューで「Save Options」を選択することにより,変更した表示構成を保存し,これ以降のデバッグ・セッションで適用することができます。

また, 第 10.10.4 項 の説明に従って,デバッガ・リソース・ファイルを編集し保存することにより,デバッガの表示構成についてのすべての属性を変更することができます。「Options」メニューから「Save Options」を選択するとき,またはローカル・デバッガ・リソース・ファイルの編集と保存を行うとき,デバッガは新しいバージョンのローカル・デバッガ・リソース・ファイル DECW$USER_DEFAULTS:VMSDEBUG.DAT を作成します。このファイルには,表示構成属性の定義が含まれています。次にデバッガを起動するとき,もっとも新しいローカル・リソース・ファイルで定義されている属性が使用され,それによって出力表示が構成されます。DCL コマンドの DELETE, RENAME,COPY を適切に使用することにより,デバッガの以前の表示構成に戻すことができます。

システムの省略時表示構成に戻すときは,OpenVMSデバッガの「Options」メニューから「Restore Default Options」を選択します。

10.10.1 デバッガ・ビューの起動時構成の定義

デバッガのビューの起動時構成を定義するには,次の手順に従ってください。

  1. デバッガの使用中に,ビューの構成を希望どおりに設定する。

  2. 「Options」メニューで「Save Options」を選択することにより,デバッガ・リソース・ファイルの新バージョンが作成される。

次にデバッガを起動すると,新しい表示構成を作成するときに最新のリソース・ファイルが使用されるようになります。

リソース・ファイル内にあるこれらのビューの定義を編集することによって ( 第 10.10.4 項 を参照 ),起動時の表示構成を定義することもできます。

10.10.2 ソース・ビューと命令ビュー内の行番号の表示と非表示

デバッガの起動時,省略時の設定により,ソース・ビューと命令ビューにはソース行番号が表示されます。デバッガの起動時に行番号を表示しないようにするには,次の手順に従ってください。

  1. デバッガの使用中に,メイン・ウィンドウ (または命令ウィンドウ) の「File」メニューで「Display Line Numbers」を選択する。そのメニュー項目の横のボタンが白抜きになり,行番号が表示されなくなる。

  2. 「Options」メニューで「Save Options」を選択し,デバッガのローカル・リソース・ファイルの新バージョンを作成する。

次にデバッガを起動すると,最新のリソース・ファイルが使用されて,新しい表示構成が作成されます。

リソース・ファイル内の次のリソースを「True」か「False」に設定することによって ( 第 10.10.4 項 を参照 ),起動時に行番号を表示するかどうかの省略時設定を決めることもできます。


DebugSource.StartupShowSourceLineno: True 
DebugInstruction.StartupShowInstLineno: True 



10.10.3 プッシュ・ボタンの変更,追加,削除,並べ替え

プッシュ・ボタン・ビューのボタンはデバッガ・コマンドと対応しています。ユーザは次の操作ができます。

  • ボタンのラベル,またはボタンに対応しているコマンドを変更する。

  • 新しいボタンを追加する。

  • ボタンを削除する。

  • ボタンを並べ替える。

注意

「Stop」ボタンの変更,削除はできません。

これ以降のデバッガ・セッションで使用できるようにこれらの変更を保存するには,「Options」メニューで「Save Options」を選択します。

第 10.10.3.1 項第 10.10.3.2 項 ,および 第 10.10.3.3 項 では, DECwindows Motif for OpenVMS ユーザ・インタフェースを使用して会話形式でプッシュ・ボタンをカスタマイズする方法について説明します。プッシュ・ボタンをカスタマイズするには,リソース・ファイルを編集する方法もあります。リソース・ファイルのボタン定義は,次のスクリプトで始まります。


DebugControl.Button 

( 例 10-1 を参照。)

ボタンのラベルまたは対応しているコマンドを変更するには,次の手順に従ってください。

  1. メイン・ウィンドウまたはオプション・ビュー・ウィンドウの「Options」メニューで「Customize Buttons...」を選択する。「Customize Buttons」ダイアログ・ボックスが表示される ( 図 10-23 を参照 )。

  2. 変更したいボタンをダイアログ・ボックスの中でクリックする。「Command」フィールドと「Label」フィールドにそのボタンのパラメータが表示される。 図 10-23 では「STEP」ボタンを選択している。

  3. ボタンのアイコンを変更するときは,ダイアログ・ボックスの「Icon」メニューをプルダウンして,定義済みアイコンを選択する。 図 10-23 に示すように,「Label」フィールドの表示が薄くなり,定義済みアイコンの内部名が表示される。アイコン自体は,ダイアログ・ボックスのプッシュ・ボタン表示に表示される。
    ボタンのラベルを変更するときは,「Icon」メニューが「None」に設定されていることを確認してから,「Label」フィールドに新しいラベルを入力する。

  4. ボタンに対応しているコマンドも変更するときは,「Command」フィールドに新しいコマンドを入力する。コマンドのオンライン・ヘルプについては, 第 8.4.3 項 を参照。
    ウィンドウで選択した名前や言語式にそのコマンドを作用させる場合は,コマンド・パラメータとして %S を指定する。たとえば,次のコマンドでは現在選択されている言語式の現在値が表示される。


    EVALUATE %s 
    


    デバッガの組み込みシンボル,またはパーセント記号 (%) で始まるその他の名前にそのコマンドを作用させる場合は,次のように2つのパーセント記号を指定する。


    EXAMINE %%NEXTLOC 
    

  5. 「Modify」をクリックする。ダイアログ・ボックスのプッシュ・ボタン表示のボタン・ラベルまたは対応しているコマンドが変更される。

  6. 「Apply」をクリックする。デバッガのプッシュ・ボタン・ビューのボタン・ラベルまたは対応しているコマンドが変更される。

これ以降のデバッガ・セッションで使用できるように変更事項を保存するときは,「Options」メニューから「Save Options」を選択します。

図 10-23 「Step」ボタン・ラベルのアイコンへの変更




プッシュ・ボタン・ビューに新しいボタンを追加し,そのボタンにデバッガ・コマンドを割り当てるには,次の手順に従ってください。

  1. 「Options」メニューで「Customize Buttons...」を選択する。「Customize Buttons」ダイアログ・ボックスが表示される ( 図 10-24 を参照)。

  2. 「Command」フィールドに新しいボタンのデバッガ・コマンドを入力する ( 第 10.10.3.1 項 を参照 )。 図 10-24 では,コマンド「RUN CP:X」を入力している。このコマンドは,X.EXE という名前のプログラムを起動する。

  3. 「Label」フィールドにそのボタンのラベルを入力するか,「Icon」メニューの中から定義済みアイコンを選択する。 図 10-24 では,「Run-X」ラベルを入力している。

  4. 「Add」をクリックする。新しいボタンがプッシュ・ボタン表示のダイアログ・ボックスに追加される

  5. 「Apply」をクリックする。デバッガのプッシュ・ボタン・ビューにボタンが追加される。

これ以降のデバッガ・セッションで使用できるように変更事項を保存するときは,「Options」メニューから「Save Options」を選択します。

図 10-24 「EXAMINE/ASCIZ」コマンドのボタンの追加



目次 索引

印刷用画面へ
プライバシー 本サイト利用時の合意事項