Jump to content 日本-日本語
製品  >  ソフトウェア  >  Linux

Intelligent Provisioning v1.0, v1.1, v1.2技術情報

Open Source & Linux

導入事例

product

ハードウェア
ソフトウェア
サービス & サポート

buy now?

HPE OPEN SERVICES
保守サービス
教育プログラム

support

OS対応表
ProLiant
Workstation
システム構成図
技術文書
FAQ
ディストリ対応表
サポート & ドライバ
リンク
SDR - 設定方法
FreeBSD
サイトマップ
HPE & Red Hat情報ポータル HPEとRed Hatが実現するオープンなイノベーション
BSD 動作確認レポート等を掲載
コンテンツに進む
29-MAY-2013
 本ページに記載してある内容は限られた評価環境に於ける検証結果に基づいたものです。本ページの情報を利用する前に予めサイト内リンク技術情報サイト外リンク保証について、ディストリビュータが提供する WEBサイト等をご覧ください。
 本ページでは、Intellignet Provisioningを利用して ProLiant Gen8シリーズに Linuxをインストールする方法について説明いたします。

Intelligent Provisioningとは

 Intelligent Provisioning(IP)は ProLiant Gen8シリーズに搭載された管理ツールです。IPは ProLiant Gen8に搭載されている insight Lights-Out Management Engineである iLO4に実装されているオフラインの統合管理ツールです。
RHEV FreeOS全般 MCP対応ディストリ SLES RHEL
 OSを導入する前のセットアップ、OSのインストール支援、ファームウェア更新、システム診断等が統一されたインターフェース経由で利用できます。従来の様に必要な際にセットアップ CDを探す必要もなく、電源投入直後に [F11]キーを押す事で即座に利用できます。利用可能なツールは下記となります。これらのツールはオフライン状況、つまり OSが稼働していない状況で利用するものですので、FreeOSでも利用する事ができます。本製品に搭載されているツールのバージョンは下記となります。
 v1.0
  - Array Configuration Utility v9.0.24.0
  - Insight Diagnostics v9.0.0.4179A
 v1.1
  - Array Configuration Utility v9.10.22.0
  - Insight Diagnostics v9.10.4458A
 v1.2
  - Array Configuration Utility v9.20.9.0
  - Insight Diagnostics v9.2.0.4545A
SLES RHEL
 v1.10以降の VID(仮想インストールディスク)にはドライバが内包されており、Dynamic SmartArrayの場合、別途 DUDメディアを別途用意する事なくインストールする事が可能です。内容については後述の `同梱されている VID内ドライバについて`セクションをご覧ください。

Linuxのインストール方法について

 ProLiant Gen8への Linuxのインストールの仕方は 2種類あります。IP経由でのインストール支援を利用する方法と、利用しない方法です。IP経由でのインストール支援を利用した場合に IPが支援を行う内容は Linuxのインストールを行う前段階迄の支援となります。
RBSUの簡易設定
SmartArrayの簡易設定
ファームウェアのアップデート

IP利用時の注意点

SLES RHEL
RHEL5.8未満で Opteronの 4200, 6200シリーズ CPUを搭載した ProLiantを利用する場合、Power Regulatorの設定は OS Controlモードに設定する必要があります。この設定は IP内では変更できませんので、別途 RBSUから変更を行う必要があります。
IP v1.10以降の VID内の Dynamic SmartArray用 hpvsaドライバを利用するには予めサイト内リンクRBSU (Advanced Options ⇒ Advanced System ROM Options)で設定を有効に変更しておく必要があります。IP v1.00の場合、hpvsaドライバは別途ダウンロードを行い USB-key等からロードする必要があります。
Dynamic SmartArrayを x86(32bit) kernelで利用する場合にはインストーラの boot:メニューで vmalloc=384Mを引き渡してください。
Dynamic SmartArrayの内 B120iを利用する場合、ahciドライバのロードを抑制する必要があります。インストーラの boot:メニューで blacklist=ahci(RHELの場合)、broken_modules=ahci(SLESの場合)を引き渡してください。
VID内のパス指定は、RHEL5, RHEL6の場合 /dev/sda内の適切なものを選択してください。SLES10の場合パス指定は不要です。SLES11の SP2を利用する場合のパス指定は、x86向けが updatedir=/linux/suse/i386-sles11.2、x86_64向けが updatedir=/linux/suse/x86_64-sles11.2となります。詳細については後述の `同梱されている VID内ドライバについて`セクションをご覧ください。
VIDが有効になっている場合、VIDが /dev/sdaとなりますので、ブートローダの導入先は /dev/sdbか /dev/cciss/c0d0へ変更する必要があります。

kISOについて

SLES RHEL
 SUSE Linux Enterprise Server 10/SP4、11/SP1をインストールするためには、kISO(kernel update ISO)イメージを入手しそのメディアをインストールメディアとして利用してください。特に SLES11/SP1は通常のメディアを利用した場合で且つ、内蔵 DVDドライブを Legacyモードで利用している場合は、インストールの途中でメディアの認識が出来なくなります(Make sure that CD number 1 is in your drive.)。

 kISOイメージの入手先はサイト外リンクこちらから。

同梱されている VID内ドライバについて

SLES RHEL
 iLO4は 4GBの NAND領域を持ち、その内の一部の領域が VID(仮想インストールディスク)として扱われます。IP v1.10以降の VIDの中には RHELと SLES向けの DUDドライバが同梱されています。v1.00の VIDの中には RPM形式の hp-amsドライバだけが同梱されています。VIDの設定は POST時に [F9]で起動するRBSUから変更できます。内容は下記となります。
 IP v1.0
.
|-- RHEL5
|   |-- hp-ams-1.0.0-570.rhel5.i386.rpm
|   `-- hp-ams-1.0.0-570.rhel5.x86_64.rpm
|-- RHEL6
|   |-- hp-ams-1.0.0-570.rhel6.i386.rpm
|   `-- hp-ams-1.0.0-570.rhel6.x86_64.rpm
|-- SLES10
|   |-- hp-ams-1.0.0-570.sles10.i386.rpm
|   |-- hp-ams-1.0.0-570.sles10.x86_64.rpm
|   `-- hpmouse-1.2.1-1.noarch.rpm
`-- SLES11
    |-- hp-ams-1.0.0-570.sles11.i386.rpm
    `-- hp-ams-1.0.0-570.sles11.x86_64.rpm
            
 IP v1.1
.
|-- redhat
|   |-- be2iscsi-2.102.200.10-rh5u4.i386.img
|   |-- be2iscsi-2.102.200.10-rh5u4.x86_64.img
|   |-- hp-ams-1.1.0-604.rhel5.i386.rpm
|   |-- hp-ams-1.1.0-604.rhel5.x86_64.rpm
|   |-- hp-ams-1.1.0-604.rhel6.i386.rpm
|   |-- hp-ams-1.1.0-604.rhel6.x86_64.rpm
|   |-- hp-ilo-8.5.0-1.rhel5.i386.rpm
|   |-- hp-ilo-8.5.0-1.rhel5.x86_64.rpm
|   |-- hpsa-3.0.0-1.rhel6.i686.dd
|   |-- hpsa-3.0.0-1.rhel6.x86_64.dd
|   |-- hpvsa-1.2.2-3.rhel5u7.i686.dd
|   |-- hpvsa-1.2.2-3.rhel5u7.x86_64.dd
|   |-- hpvsa-1.2.2-3.rhel5u8.i686.dd
|   |-- hpvsa-1.2.2-3.rhel5u8.x86_64.dd
|   |-- hpvsa-1.2.2-3.rhel6u1.i686.dd
|   |-- hpvsa-1.2.2-3.rhel6u1.x86_64.dd
|   |-- hpvsa-1.2.2-3.rhel6u2.i686.dd
|   `-- hpvsa-1.2.2-3.rhel6u2.x86_64.dd
`-- suse
    |-- hp-ams-1.1.0-604.sles10.i386.rpm
    |-- hp-ams-1.1.0-604.sles10.x86_64.rpm
    |-- hp-ams-1.1.0-604.sles11.i386.rpm
    |-- hp-ams-1.1.0-604.sles11.x86_64.rpm
    |-- hp-ilo-9.0.0-183.sles10.i386.rpm
    |-- hp-ilo-9.0.0-183.sles10.x86_64.rpm
    |-- hpmouse-1.2.1-1.noarch.rpm
    |-- i386-sles10
    |   |-- install
    |   |   |-- hpvsa-kmp-bigsmp-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-debug-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-default-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-kdump-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-kdumppae-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-smp-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-vmi-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-vmipae-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   |-- hpvsa-kmp-xenpae-1.2.2_2.6.16.60_0.85.1-3.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       |-- hpvsa.ko
    |       `-- module.order
    |-- i386-sles11
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.2_2.6.32.12_0.7-3.i586.rpm
    |   |   |-- hpvsa-kmp-pae-1.2.2_2.6.32.12_0.7-3.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.2_2.6.32.12_0.7-3.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       |-- hpvsa.ko
    |       `-- module.order
    |-- i386-sles11.2
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.2_3.0.13_0.27-3.i586.rpm
    |   |   |-- hpvsa-kmp-pae-1.2.2_3.0.13_0.27-3.i586.rpm
    |   |   |-- hpvsa-kmp-trace-1.2.2_3.0.13_0.27-3.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.2_3.0.13_0.27-3.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       |-- hpvsa.ko
    |       `-- module.order
    |-- x86_64-sles10
    |   |-- install
    |   |   |-- hpvsa-kmp-debug-1.2.2_2.6.16.60_0.85.1-3.x86_64.rpm
    |   |   |-- hpvsa-kmp-default-1.2.2_2.6.16.60_0.85.1-3.x86_64.rpm
    |   |   |-- hpvsa-kmp-kdump-1.2.2_2.6.16.60_0.85.1-3.x86_64.rpm
    |   |   |-- hpvsa-kmp-smp-1.2.2_2.6.16.60_0.85.1-3.x86_64.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.2_2.6.16.60_0.85.1-3.x86_64.rpm
    |   |   `-- update.post
    |   `-- modules
    |       |-- hpvsa.ko
    |       `-- module.order
    |-- x86_64-sles11
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.2_2.6.32.12_0.7-3.x86_64.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.2_2.6.32.12_0.7-3.x86_64.rpm
    |   |   `-- update.post
    |   `-- modules
    |       |-- hpvsa.ko
    |       `-- module.order
    `-- x86_64-sles11.2
        |-- install
        |   |-- hpvsa-kmp-default-1.2.2_3.0.13_0.27-3.x86_64.rpm
        |   |-- hpvsa-kmp-trace-1.2.2_3.0.13_0.27-3.x86_64.rpm
        |   |-- hpvsa-kmp-xen-1.2.2_3.0.13_0.27-3.x86_64.rpm
        |   `-- update.post
        `-- modules
            |-- hpvsa.ko
            `-- module.order
            
 IP v1.2
.
|-- redhat
|   |-- be2iscsi-2.102.200.10-rh5u4.i386.img
|   |-- be2iscsi-2.102.200.10-rh5u4.x86_64.img
|   |-- hp-ams-1.2.0-781.26.rhel5.i386.rpm
|   |-- hp-ams-1.2.0-781.36.rhel5.x86_64.rpm
|   |-- hp-ams-1.2.0-782.27.rhel6.i686.rpm
|   |-- hp-ams-1.2.0-782.31.rhel6.x86_64.rpm
|   |-- hpvsa-1.2.4-4.rhel5u7.i686.dd
|   |-- hpvsa-1.2.4-4.rhel5u7.x86_64.dd
|   |-- hpvsa-1.2.4-4.rhel5u8.i686.dd
|   |-- hpvsa-1.2.4-4.rhel5u8.x86_64.dd
|   |-- hpvsa-1.2.4-4.rhel6u1.i686.dd
|   |-- hpvsa-1.2.4-4.rhel6u1.x86_64.dd
|   |-- hpvsa-1.2.4-4.rhel6u2.i686.dd
|   |-- hpvsa-1.2.4-4.rhel6u2.x86_64.dd
|   |-- hpvsa-1.2.4-4.rhel6u3.i686.dd
|   `-- hpvsa-1.2.4-4.rhel6u3.x86_64.dd
`-- suse
    |-- hp-ams-1.2.0-782.26.sles10.i386.rpm
    |-- hp-ams-1.2.0-782.26.sles11.i386.rpm
    |-- hp-ams-1.2.0-782.27.sles10.x86_64.rpm
    |-- hp-ams-1.2.0-782.27.sles11.x86_64.rpm
    |-- hpmouse-1.2.1-1.noarch.rpm
    |-- i386-sles10
    |   |-- install
    |   |   |-- hpvsa-kmp-bigsmp-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-debug-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-default-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-kdump-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-kdumppae-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-smp-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-vmi-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-vmipae-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.4-4.sles10sp4.i586.rpm
    |   |   |-- hpvsa-kmp-xenpae-1.2.4-4.sles10sp4.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       `-- hpvsa.ko
    |-- i386-sles11
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.4-4.sles11sp1.i586.rpm
    |   |   |-- hpvsa-kmp-pae-1.2.4-4.sles11sp1.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.4-4.sles11sp1.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       `-- hpvsa.ko
    |-- i386-sles11.2
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.4-4.sles11sp2.i586.rpm
    |   |   |-- hpvsa-kmp-pae-1.2.4-4.sles11sp2.i586.rpm
    |   |   |-- hpvsa-kmp-trace-1.2.4-4.sles11sp2.i586.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.4-4.sles11sp2.i586.rpm
    |   |   `-- update.post
    |   `-- modules
    |       `-- hpvsa.ko
    |-- x86_64-sles10
    |   |-- install
    |   |   |-- hpvsa-kmp-debug-1.2.4-4.sles10sp4.x86_64.rpm
    |   |   |-- hpvsa-kmp-default-1.2.4-4.sles10sp4.x86_64.rpm
    |   |   |-- hpvsa-kmp-kdump-1.2.4-4.sles10sp4.x86_64.rpm
    |   |   |-- hpvsa-kmp-smp-1.2.4-4.sles10sp4.x86_64.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.4-4.sles10sp4.x86_64.rpm
    |   |   `-- update.post
    |   `-- modules
    |       `-- hpvsa.ko
    |-- x86_64-sles11
    |   |-- install
    |   |   |-- hpvsa-kmp-default-1.2.4-4.sles11sp1.x86_64.rpm
    |   |   |-- hpvsa-kmp-xen-1.2.4-4.sles11sp1.x86_64.rpm
    |   |   `-- update.post
    |   `-- modules
    |       `-- hpvsa.ko
    `-- x86_64-sles11.2
        |-- install
        |   |-- hpvsa-kmp-default-1.2.4-4.sles11sp2.x86_64.rpm
        |   |-- hpvsa-kmp-trace-1.2.4-4.sles11sp2.x86_64.rpm
        |   |-- hpvsa-kmp-xen-1.2.4-4.sles11sp2.x86_64.rpm
        |   `-- update.post
        `-- modules
            `-- hpvsa.ko
            

IP利用後の起動順変更について

 Intelligent Provisioning経由で OSをインストールした場合、ブートデバイスの優先順位として HDDがプライマリに変更されます。このためローカル接続した DVDドライブ、iLO4の仮想メディアとして接続した DVD共に、それらのメディアからシステムは起動しません。これらのメディアからシステムを起動させるには、サイト内リンクRBSUの Standard Boot Orderの IPL:1を CD-ROMに戻す必要があります。

IP利用後の VIDデバイスの認識について

VID  Intelligent Provisioning経由で OSをインストールした場合や、手動で VID(仮想インストールディスク)を有効にした場合、ディストリビューションによっては `VID`として自動マウントが行われます。VIDを無効にするにはPOST時に [F9]で起動する RBSUから変更できます。
このページのトップへ戻る
印刷用画面へ印刷用画面へ
プライバシー ご利用条件・免責事項